使用者工具

網站工具


tech:centos5_php

CentOS5 升級 PHP 5.2 的方式

現在 PHP 官方網站已經釋出到 5.3, 但目前穩定運作使用的 CentOS5 還是提供 PHP 5.1 (CentOS6 已提供 PHP 5.3), 因此對於愈來愈多 OpenSource PHP 專案都強調採用 PHP 5.2 以上的版本要求, 就讓使用 CentOS5 的用戶有對 PHP 相關套件升級為 5.2 版本的需求..

其實透過 Google 大神輸入關鍵字, 很快就可找到在 CentOS 的 Wiki 頁面有此說明.. 這也是看到最簡單的升級方式, 副作用也應該是最少的.

增加 yum 的設定檔

vi /etc/yum.repos.d/CentOS-Testing.repo
[c5-testing]
name=CentOS-5 Testing
baseurl=http://dev.centos.org/centos/$releasever/testing/$basearch/
enabled=1
gpgcheck=1
gpgkey=http://dev.centos.org/centos/RPM-GPG-KEY-CentOS-testing
includepkgs=php*

直接使用 CentOS5 開發版本的 php 套件

執行 yum 的更新

yum update

這樣就可升級完成

重新啟動 httpd

service httpd restart

參考網址

tech/centos5_php.txt · 上一次變更: 2011/11/08 11:21 由 jonathan