tech:vm_upgradekernel

更新 linux Kernel 後 VMWare 與 VirtualBox 重新編譯程序

當 Linux Kernel 更版後, vmware 與 vboxdrv 就無法自動起來, 因為在新版的 kernel module 內已經找不到相關的檔案, 所以必須執行以下的程序重新 Complier 新版的 Module

- 環境相關

  • kernel 的 devel / headers 必須安裝 點下看 kernel-2.6.18-53 的例子
  • gcc 相關的 complier 與 lib

- vmware

su - root
vmware-config.pl

經過這工具指令的執行過後, 就會自動將 vmware 帶起來

- vboxdrv

su - root
/etc/init.d/vboxdrv setup

經過這工具指令的執行過後, 就完成自動編譯

看之前複雜版本

tech/vm_upgradekernel.txt · 上一次變更: 2009/03/03 00:58 由 jonathan